Podio is temporary unavailable

Incident Report for Podio Status Page

Resolved

All Podio operations have been restored to normal, and we do not anticipate any further performance impact. We have identified the source of the issue and are currently working with our database provider to finalize the root cause. Thank you for your patience as we continue to monitor and ensure stability.
Posted 24 days ago. Mar 12, 2025 - 13:51 EDT

Update

All operations are back to normal. But we continue monitoring the performance and are working with our database provider to figure out the root cause to avoid this issue reoccurring.
Posted 24 days ago. Mar 12, 2025 - 11:56 EDT

Monitoring

All operations are getting back to normal. We are monitoring the performance while we work with our database provider to figure out the root cause of today's incident.
Posted 24 days ago. Mar 12, 2025 - 11:42 EDT

Update

The issue has been identified and we are working on a fix. Podio is accessible again now, but some operations might still face delays.
Posted 24 days ago. Mar 12, 2025 - 11:34 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted 24 days ago. Mar 12, 2025 - 11:31 EDT

Update

We continue to actively investigate this issue.
Posted 24 days ago. Mar 12, 2025 - 11:25 EDT

Investigating

Podio is inaccessible. We are currently investigating this issue.
Posted 24 days ago. Mar 12, 2025 - 11:09 EDT
This incident affected: Web, API, Email, Advanced Workflow Automation, and Advanced Workflow Automation Failover Queue.