Podio web app is not responsive
Incident Report for Podio
Resolved
The issue has been identified as a one-time glitch. Team has put in a fix to get Podio back up now. We are also working, in parallel, to ensure this particular issue does not repeat in future. Thanks for your patience.
Posted Dec 03, 2019 - 02:31 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 03, 2019 - 02:02 EST
Investigating
We are actively working to address this issue.
Posted Dec 03, 2019 - 01:51 EST
This incident affected: Web, API, and GlobiFlow Workflow Automation.