Citrix Podio customers may have experienced issues...

Incident Report for Podio Status Page

Resolved

At this time, we believe that the issues have been fully resolved.

We will continue to monitor closely.

If any further issues are seen, please contact Citrix Technical Support.
Posted 3 years ago. Oct 06, 2022 - 13:57 EDT

Monitoring

Impact:

Citrix Podio users may have experienced latency issues and errors accessing the service.

Current Status:

At this point, the issue seems to have recovered. Citrix Engineering will continue to monitor the service.

Next Steps:

An update will be provided when the issue is fully resolved. If any further issues are seen, please contact Citrix Technical Support.
Posted 3 years ago. Oct 06, 2022 - 12:18 EDT
This incident affected: Web, API, Email, Advanced Workflow Automation, and Advanced Workflow Automation Failover Queue.