Podio is down

Incident Report for Podio Status Page

Resolved

This incident has been resolved.
Posted Jan 22, 2025 - 20:35 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 22, 2025 - 18:12 EST

Investigating

Podio is currently down. Our Operations team is looking to find the cause and fix the problem. We will update this space as soon as possible.
Posted Jan 22, 2025 - 17:51 EST
This incident affected: Web.