Wokflow automation intermittent availability
Incident Report for Citrix Podio Status Page
Resolved
Workflow automation is now operating normally.
Posted Feb 15, 2021 - 15:51 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 15, 2021 - 15:47 EST
Investigating
We are currently investigating this issue.
Posted Feb 15, 2021 - 15:11 EST
This incident affected: Advanced Workflow Automation.