Podio item creation is Slow
Incident Report for Citrix Podio Status Page
Resolved
This incident has been resolved.
Posted Feb 03, 2020 - 14:04 EST
Investigating
We are currently investigating this issue.
Posted Feb 03, 2020 - 13:04 EST
This incident affected: Web.