Old user interface experiencing delays loading apps and data

Incident Report for Podio Status Page

Resolved

Citrix Podio services are no longer experiencing issues. The Citrix engineering team has resolved the issue, but will continue to monitor and take action internally to better avoid local issues for users in the future. We will conduct full root cause analysis internally to avoid same issue from occurring in the future.

This will be the last communication on this Incident. Please get in touch with Citrix Support Team in case the issue persists.
Posted Mar 29, 2022 - 21:25 EDT

Monitoring

Citrix Content Collaboration (Podio) service is no longer experiencing issues. The Citrix engineering team will continue to monitor the service.
Posted Mar 29, 2022 - 20:53 EDT

Investigating

We are currently investigating this issue.
Posted Mar 29, 2022 - 19:57 EDT

Update

We are receiving reports that apps are not loading for new user interface for some customers, and team is investigating what might be causing this.
Posted Mar 29, 2022 - 19:11 EDT

Monitoring

We are aware of delays loading apps and data if you are using Podio in the old user interface (soon to be phased out) - if you do see delays loading apps, we recommend you to try the following for improved performance: Go to "My account" in the top right corner, then select "Switch to new look" for a better experience. You might also need to clear browser cache to fix any issues - and by now Podio should be running much better for you. If you are already seeing smooth performance, please disregard this note.
Posted Mar 29, 2022 - 16:08 EDT
This incident affected: Web and API.