Increased Error Rates
Incident Report for Citrix Podio Status Page
Resolved
This incident has been resolved.
Posted Apr 17, 2021 - 09:05 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 16, 2021 - 16:55 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 16, 2021 - 16:24 EDT
Investigating
We are currently investigating this issue.
Posted Apr 16, 2021 - 14:53 EDT
This incident affected: API and Advanced Workflow Automation.