Users may not be receiving emails from Podio

Incident Report for Podio Status Page

Resolved

This incident has been resolved.
Posted 1 year ago. Feb 05, 2024 - 11:01 EST

Monitoring

A fix has been implemented for this and email notifications and Email to App functionality should be up and running again. We'll continue to monitor the situation.
Posted 1 year ago. Feb 05, 2024 - 09:27 EST

Update

We are continuing to investigate this issue.
Posted 1 year ago. Feb 05, 2024 - 08:04 EST

Investigating

We are investigating an incident affecting email notifications and Podio's Email to App functionality. The team is investigating and working to fix the issue.
Posted 1 year ago. Feb 05, 2024 - 07:11 EST
This incident affected: Email.