Podio end-users may be experiencing issues with Excel export
Incident Report for Citrix Podio Status Page
Resolved
At this point excel import/export jobs have been successfully processing for the last 5 hours. We apologize for the inconveniences this event has caused.
Posted May 05, 2022 - 16:23 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 05, 2022 - 10:58 EDT
Investigating
We are currently investigating this issue.
Posted May 05, 2022 - 10:03 EDT
This incident affected: Web and API.