Background tasks like data export, import and calculations, etc. running slow
Incident Report for Podio
Resolved
This incident has been resolved.
Posted May 17, 2020 - 22:03 EDT
Identified
The issue has been identified. The delay is now reducing, however it will need some more time to come back to normal.
Posted May 17, 2020 - 21:27 EDT
Investigating
We are currently investigating this issue.
Posted May 17, 2020 - 19:47 EDT
This incident affected: Web.