Workflow Automation Email Not Delivering
Incident Report for Citrix Podio Status Page
Resolved
This incident has been resolved. Email is delivering as expected.
Posted Oct 28, 2020 - 10:07 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 28, 2020 - 09:56 EDT
Investigating
We are currently investigating this issue.
Posted Oct 28, 2020 - 09:48 EDT
This incident affected: Advanced Workflow Automation.