Podio is Slow - Response Times Elevated
Incident Report for Podio Status Page
Resolved
This incident has been resolved.
Posted Nov 09, 2019 - 12:30 EST
Monitoring
We've identified the issue and continue to monitor.
Posted Nov 09, 2019 - 10:49 EST
Investigating
Podio appears to be running slow. We are investigating elevated response times. Updates will be posted here as we have them.
Posted Nov 09, 2019 - 10:07 EST
This incident affected: Web and API.