Workflow automation trigger delay
Incident Report for Citrix Podio Status Page
Resolved
The queue is stable and we do not anticipate further issues. We apologize for the inconvenience caused.
Posted Mar 08, 2021 - 17:25 EST
Update
The Podio trigger queue has recovered and we will continue to monitor.
Posted Mar 08, 2021 - 14:53 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 08, 2021 - 13:26 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 08, 2021 - 11:45 EST
This incident affected: Advanced Workflow Automation.