Background tasks like data export, import and calculations, etc. running slow
Incident Report for Podio Status Page
Resolved
This incident has been resolved.
Posted Apr 27, 2020 - 06:15 EDT
Identified
We have identified the issue and are working on remediation.
Posted Apr 27, 2020 - 04:25 EDT
This incident affected: Web and API.