Podio users may be unable to access Podio Web App

Incident Report for Podio Status Page

Resolved

This incident has been resolved. We regret the inconvenience caused.
Posted 2 years ago. May 29, 2023 - 09:51 EDT

Monitoring

Podio is back operational we are monitoring..
Posted 2 years ago. May 29, 2023 - 08:43 EDT

Investigating

We are currently investigating this issue.
Posted 2 years ago. May 29, 2023 - 08:35 EDT
This incident affected: Web.