Slowdowns and degraded performance
Incident Report for Podio Status Page
Resolved
We believe to have resolved the issue causing slowness, and have a plan to attack if problem re-occurs tomorrow. We are very sorry for the inconvenience and slowdown in productivity as a result of this incident. We are taking actions internally to avoid the same problem to re-appear, and also have a faster plan for resolution going forward, including better monitoring, should this problem re-occur despite our best efforts.
Posted Nov 30, 2022 - 14:45 EST
Monitoring
A fix has been implemented and we are monitoring the results. Thanks for your patience working with slow Podio, we hope and aim to have better speed going forward.
Posted Nov 30, 2022 - 13:04 EST
Identified
We believe to have identified a potential solution and fixes were rolled out between 12.30-12.45 EST / 18.30-18.45 CET. We will move the incident to monitoring while we monitor impact across the system.
Posted Nov 30, 2022 - 13:03 EST
Update
Update Wednesday Nov 30: We made changes to improve processing of search related tasks on Nov 29 and have seen improvements in processing of work related to search indexing since updates were made yesterday. We are still investigating reports of Podio being slower than normal and investigating root-cause causing the slow experience. We will provide new updates when we are able to identify potential root cause.
Posted Nov 30, 2022 - 09:58 EST
Update
We have seen improvements and delays improving over the last hour, however we are still investigating cause of the bottleneck earlier this morning EST, and is still not confident to have a clear root cause identified.

Podio performance is back to normal with currently only slight delays of search indexing of new work added. We will keep incident open until root cause has been identified to avoid same slowdown tomorrow.
Posted Nov 29, 2022 - 16:01 EST
Update
Podio performance in general has improved since initial spike of error rates around 10.46-10.53 EST however we continue to investigate bottlenecks on the platform making experience slower than normal. Podio is functioning as expected just slower than normal.
Posted Nov 29, 2022 - 13:04 EST
Update
We are continuing to investigate this issue.
Posted Nov 29, 2022 - 12:08 EST
Investigating
We are investigating reports of slowdowns in Podio
Posted Nov 29, 2022 - 11:35 EST
This incident affected: Web and API.