Citrix Podio is seeing slower responses
Incident Report for Citrix Podio Status Page
Resolved
This incident has been resolved.
Posted Apr 25, 2022 - 11:52 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 25, 2022 - 11:37 EDT
Investigating
We are currently investigating this issue.
Posted Apr 25, 2022 - 10:50 EDT
This incident affected: Web and API.