Blog.podio.com is down
Incident Report for Podio
Resolved
Blog.podio.com went down at 01:52 PM UTC and recovered at 02:34 PM UTC. Blog is now up and running, we apologize for any inconvenience this may have caused you.
Posted 4 months ago. Mar 14, 2019 - 10:43 EDT
Investigating
We are currently investigating the issue.
Posted 4 months ago. Mar 14, 2019 - 10:28 EDT