Podio users may be facing issues with file download
Incident Report for Podio Status Page
Resolved
The incident has been resolved
Posted Nov 03, 2022 - 12:48 EDT
Monitoring
We do not see errors anymore. We will still continue to monitor the situation
Posted Nov 03, 2022 - 12:04 EDT
Investigating
The file download issue should now be resolved. We are now working on investigating some other side effects that have been reported.
Posted Nov 03, 2022 - 10:48 EDT
Monitoring
A fix has been implemented and we are currently monitoring the situation
Posted Nov 03, 2022 - 09:28 EDT
Identified
The team has identified the issue and is working on a fix
Posted Nov 03, 2022 - 07:38 EDT
Investigating
Podio users may be seeing error - "Sorry, you don't have access to this file" while trying to download file
Posted Nov 03, 2022 - 07:36 EDT
This incident affected: Web.