Web and API response time is slower than usual
Incident Report for Citrix Podio Status Page
Resolved
This incident has been resolved.
Posted Mar 29, 2021 - 13:17 EDT
Investigating
We are currently investigating this issue.
Posted Mar 29, 2021 - 12:08 EDT
This incident affected: Web and API.