Some users maybe unable to access Podio

Incident Report for Podio Status Page

Resolved

This incident has been resolved. We regret the inconvenience caused to our customers.
Posted 2 years ago. Dec 20, 2022 - 11:28 EST

Monitoring

We are monitoring the situation now
Posted 2 years ago. Dec 20, 2022 - 10:58 EST

Identified

The team has identified the issue and a fixed it. We have seen the intermittent errors come down and Podio should now be accessible to all users. We will continue to monitor the situation before we mark this as resolved.
Posted 2 years ago. Dec 20, 2022 - 10:55 EST

Update

The errors have gone down and users should now be able to access Podio as expected. However, the team continues to investigate the reason behind the spike.
Posted 2 years ago. Dec 20, 2022 - 10:03 EST

Update

We continue investigating the issue impacting customers attempting to access Citrix Podio. Users may face intermittent errors when attempting to access the service.
Posted 2 years ago. Dec 20, 2022 - 09:36 EST

Investigating

We are currently investigating an issue impacting customers ability to access Citrix Podio.
Posted 2 years ago. Dec 20, 2022 - 09:20 EST
This incident affected: Web and API.