Podio customers using Microsoft or ShareFile SSO may be experiencing issues logging in
Incident Report for Citrix Podio Status Page
Resolved
This incident has been resolved. We regret the inconvenience caused to our customers.
Posted Jun 15, 2022 - 06:16 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 15, 2022 - 05:49 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 15, 2022 - 05:48 EDT
Update
Podio customers who are using Microsoft or ShareFile SSO may be experiencing issues logging in. The Citrix Engineering team is currently investing and will update the status accordingly.
Posted Jun 15, 2022 - 05:35 EDT
Investigating
We are currently investigating this issue.
Posted Jun 15, 2022 - 05:31 EDT
This incident affected: Web.