Issue with Podio Email notifications

Incident Report for Podio Status Page

Resolved

The issue has been resolved and users should now receive emails from Podio as expected.
Posted 2 years ago. Dec 19, 2022 - 09:38 EST

Monitoring

A fix has been implemented and we are monitoring the system to ensure Podio email notifications are going through as expected. Thank you for your patience.
Posted 2 years ago. Dec 19, 2022 - 09:20 EST

Identified

The team has identified the root cause for emails not going out to some Podio users and a fix is being worked on
Posted 2 years ago. Dec 19, 2022 - 04:56 EST

Investigating

Some Podio users may not be receiving Podio emails. The team is working on fixing this.
Posted 2 years ago. Dec 19, 2022 - 04:50 EST
This incident affected: Email.