Citrix Podio experiencing background tasks delays
Incident Report for Citrix Podio Status Page
Resolved
Current Status: At this time, we believe that the issues affecting the Citrix Podio background tasks and Workflow Automation Service have been fully resolved. We will continue to monitor closely. Please note that some works might require to be re-triggered. We apologize for the inconveniences this issue caused.
Posted May 04, 2022 - 15:14 EDT
Update
These delays are impacting Advanced Workflow Automation as well. Our engineering team is actively investigating the issue.
Posted May 04, 2022 - 13:48 EDT
Investigating
We are currently investigating this issue.
Posted May 04, 2022 - 13:31 EDT
This incident affected: Web, API, and Advanced Workflow Automation.