Podio Workflow Automation is experiencing delays
Incident Report for Podio Status Page
Resolved
This incident has been resolved.
Posted May 20, 2024 - 16:02 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 20, 2024 - 16:01 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 20, 2024 - 15:54 EDT
Update
We are continuing to investigate this issue.
Posted May 20, 2024 - 15:10 EDT
Investigating
Podio Workflow Automation is currently seeing a slow down. We're investigating the cause and will post updates here as soon as we have them.
Posted May 20, 2024 - 15:09 EDT
This incident affected: API and Advanced Workflow Automation.