Citrix Podio Workflow Automation Service may be experiencing issues...
Incident Report for Citrix Podio Status Page
Resolved
Current Status: At this time, we believe that the issues affecting the Citrix Podio Workflow Automation Service have been fully resolved. We will continue to monitor closely.

Next Steps: If any further issues are seen, please contact Citrix Technical Support.
Posted Aug 09, 2021 - 11:28 EDT
Monitoring
Current Status: At this time, we believe that the issues affecting the Citrix Podio service have been resolved. We will continue to monitor closely.

Next Steps: If any further issues are seen, please contact Citrix Technical Support.
Posted Aug 09, 2021 - 11:12 EDT
Investigating
Impact: Citrix Podio workflow automation is experiencing issues with queue delays causing workflows to be triggered slower than normal.

Current Status: The Citrix Engineering team is engaged and investigating the issue. At present there are no identifiable work arounds or ETA for a fix.

Next Steps: A further update will be provided within 60 minutes.
Posted Aug 09, 2021 - 11:01 EDT