Podio may be inaccessible

Incident Report for Podio Status Page

Resolved

The incident has been resolved.
Posted 1 year ago. May 22, 2024 - 02:32 EDT

Monitoring

The fix has been implemented. Podio should be up and running for all customers now.
We regret the inconvenience caused to our users.
Posted 1 year ago. May 22, 2024 - 02:29 EDT

Identified

The issue has been identified and a fix is being deployed.
Posted 1 year ago. May 22, 2024 - 02:23 EDT

Investigating

We are continuing to investigate this issue.
The Podio Engineering team is engaged and working on a fix. We regret the inconvenience caused and are trying our best to get Podio up and running again
Posted 1 year ago. May 22, 2024 - 02:12 EDT
This incident affected: Web, API, Email, Advanced Workflow Automation, and Advanced Workflow Automation Failover Queue.