Search errors
Incident Report for Citrix Podio Status Page
Resolved
This incident has been resolved.
Posted Jan 08, 2021 - 12:42 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 08, 2021 - 12:13 EST
Investigating
We pushed a fix that did not improve the experience. Our team continues to actively investigate and troubleshoot to reduce the error rates
Posted Jan 08, 2021 - 11:55 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 08, 2021 - 10:40 EST
This incident affected: Web, API, and Advanced Workflow Automation.