Podio Workflow Automation Authenticating to RightSignature Failures

Incident Report for Podio Status Page

Resolved

Podio Workflow Automation now can successfully connect to RightSignature and all functionality is restored.
Posted 2 years ago. May 22, 2023 - 16:44 EDT

Investigating

Podio Workflow Automation customers may be experiencing issues with authenticating to RightSignature. We are investigating this issue and we will provide updates here as soon as possible.
Posted 2 years ago. May 22, 2023 - 15:10 EDT
This incident affected: Advanced Workflow Automation.