Delay in background tasks and calculations
Incident Report for Podio
Resolved
This incident has been resolved.
Posted Nov 08, 2019 - 20:16 EST
Monitoring
We are experiencing delays in background tasks like import, export and calculations.
Posted Nov 08, 2019 - 13:50 EST
This incident affected: Web and API.