Podio API response delays

Incident Report for Podio Status Page

Postmortem

Podio Server took too long to respond – July 2, 2025

Summary of Impact

On July 2nd 2025, part of Podio customers started facing high rate of server timeout errors when creating or updating application items. The delays and disruptions caused by the degraded server API performance were sporadic and lasting for several minutes each time.

Root Cause

On July 2nd 2025, our alert system noticed a sporadic increase in Podio related errors when executing workflows. In the meanwhile, the customer support team also received several reports for server errors while executing actions on app items – creating new or updating existing items. Both, the error rate increases and customer reports were intermittent, happening a couple of times during the day for several minutes and experienced by only part of Podio customers. The problem was traced to an end-user's workflow that was incorrectly configured and resulted in locking our database. This, in turn, made items management unavailable while the workflow execution was in progress.

Mitigation

After identifying the root cause, Podio team took the following actions:

  • Engineering reported the traced workflow
  • Customer support worked closely with the end-user to deactivate the workflow in order to mitigate the configuration issue. They also helped optimize the workflow to prevent this issue from re-occurring.

The issue was confirmed resolved and fixed as of July 16th, 2025.

Next Steps

  1. Conduct review of Podio workflows and the specific workflow type that was the root cause for this incident
  2. Optimize and improve performance of Podio workflows while processing high volume of data
Posted Aug 06, 2025 - 11:59 EDT

Resolved

We have completed steps to restore stability to the customer experience with Podio web and API.

No further impact has been observed and we are considering this issue to be resolved. If you are still experiencing any issues, please let us know via support at https://support.sharefile.com/s/
Posted Jul 07, 2025 - 09:33 EDT

Monitoring

Podio performance is back to normal. We'll continue monitoring system metrics and performance.
Posted Jul 07, 2025 - 02:46 EDT

Investigating

There are some more reports for degraded API communication performance. We are currently investigating potential causes.
Posted Jul 03, 2025 - 11:33 EDT

Identified

There are some more reports for degraded API communication performance. We are currently investigating potential causes.
Posted Jul 03, 2025 - 11:33 EDT

Monitoring

Podio performance is back to normal. We'll continue monitoring system metrics and performance.
Posted Jul 03, 2025 - 11:29 EDT

Investigating

There are some more reports for degraded API communication performance. We are currently investigating potential causes.
Posted Jul 03, 2025 - 06:14 EDT

Monitoring

Podio performance is back to normal. We'll continue monitoring system metrics and performance.
Posted Jul 02, 2025 - 23:59 EDT

Identified

The issue has been identified and we are actively working on a resolution. We expect the experience to be back to normal and we'll continue monitoring system performance.
Posted Jul 02, 2025 - 18:08 EDT

Investigating

We are investigating customer reports of an issue impacting performance of Podio causing slowness in the application and increased error rates. We will provide updates here as soon as possible.

Updates every 30 minutes (every 15 min for hard down):

We are continuing to investigate this issue.
Posted Jul 02, 2025 - 13:35 EDT
This incident affected: API.