Intermittent Delays on Podio
Incident Report for Citrix Podio Status Page
Resolved
This incident has been resolved.
Posted Oct 04, 2021 - 15:20 EDT
Update
We are continuing to investigate this issue.
Posted Oct 04, 2021 - 12:39 EDT
Investigating
We are currently investigating this issue.
Posted Oct 04, 2021 - 12:38 EDT
This incident affected: Web and API.