Delay in background tasks and calculations
Incident Report for Citrix Podio Status Page
Resolved
This Incident has been resolved. We apologise for the inconvenience caused
Posted Jul 07, 2022 - 01:49 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 07, 2022 - 01:31 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 07, 2022 - 01:25 EDT
Investigating
We are currently investigating this issue.
Posted Jul 07, 2022 - 01:21 EDT
This incident affected: Web and API.