Delays for background tasks - File imports/exports, calendar sync, and background cleanups

Incident Report for Podio Status Page

Resolved

We have completed steps to restore stability to the customer experience with Podio background tasks.

No further impact has been observed and we are considering this issue to be resolved. If you are still experiencing any issues, please let us know via support at Help Center: https://support.sharefile.com/s/
Posted Jun 16, 2025 - 16:02 EDT

Monitoring

We are seeing better performance of background tasks based on team efforts to resolve and are actively monitoring.
Posted Jun 16, 2025 - 15:17 EDT

Identified

The issue has been identified and we are actively working on a resolution. We expect the experience to be back to normal shortly.
Posted Jun 16, 2025 - 15:05 EDT

Update

We are continuing to investigate this issue.
Posted Jun 16, 2025 - 14:30 EDT

Investigating

We are investigating customer reports of an issue impacting performance of certain background tasks like file imports/exports, calendar sync, and background cleanups. Users are likely to see delays in the affected operations. We will provide updates here with more details as soon as possible.
Posted Jun 16, 2025 - 13:20 EDT
This incident affected: Web.