Podio is Slow - Response Times Elevated
Incident Report for Citrix Podio Status Page
Resolved
This incident has been resolved.
Posted Mar 09, 2021 - 17:06 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 09, 2021 - 16:13 EST
Investigating
We are currently investigating this issue.
Posted Mar 09, 2021 - 14:53 EST
This incident affected: Web and API.