Podio Notifications Not Being Delivered

Incident Report for Podio Status Page

Resolved

Email notifications are now working as expected and the past backlog has also been cleared. We regret the inconvenience caused to our users.
Posted 1 year ago. Feb 01, 2024 - 09:29 EST

Monitoring

A fix has been implemented and users will start receiving new and pending notifications soon. We'll keep monitoring until the notification backlog gets cleared
Posted 1 year ago. Jan 31, 2024 - 23:54 EST

Identified

The issue has been identified and a fix is being implemented.
Posted 1 year ago. Jan 31, 2024 - 23:52 EST

Investigating

The Podio Engineer team is aware of notifications not being delivered, and is working to address the issue.
Posted 1 year ago. Jan 31, 2024 - 16:26 EST
This incident affected: Email.