Podio customer, who are using Google SSO, may be experiencing issues logging in.
Incident Report for Citrix Podio Status Page
Resolved
We have upgraded our system to work with Google Single Sign-on(SSO). If your Google accounts are connected for syncing calendar, contacts, drive, etc. you will need to reconnect your accounts for the syncing to resume. If you have any further issues, please contact Citrix Technical Support.
Posted May 05, 2022 - 07:55 EDT
Investigating
Podio customers, who are using Google SSO, may be experiencing issues logging in. The Citrix Engineering team is currently investing and will update the status accordingly.
Posted May 04, 2022 - 18:28 EDT
This incident affected: Web.