Citrix Podio is seeing slower responses and increased errors
Incident Report for Citrix Podio Status Page
Resolved
We feel comfortable to have resolved the issues causing delays for Podio last week, therefore marking this as resolved. Please be aware if you still see issues with Podio loading slow, it might help you to either clear your browser cache or move to our new user interface with improved performance and faster loading of app views. Go to "My account", "Switch to new look" from the top blue bar to ensure you use the new experience with faster performance.
Posted Mar 29, 2022 - 11:08 EDT
Update
We continue to monitor performance and speed for Podio infrastructure this week. We have seen improved performance the last 3 days after fixes has been made, however we are still tweaking the system to ensure a better experience overall. The last 2 days we have seen delays with real-time updates to items, comments and notifications, specifically in US time zone and are working behind the scenes to improve.

We will keep this incident open and monitoring until Monday so we can confirm we have fixed the underlying issue when we have the highest load on the platform, which usually happens on Mondays.

Thanks for your patience as we work through optimizing the system.
Posted Mar 25, 2022 - 09:50 EDT
Monitoring
A fix has been implemented and we are currently monitoring the issue.
Posted Mar 23, 2022 - 09:15 EDT
Update
Current Status: The Citrix Engineering Team has implemented a temporary fix and we are seeing performance improve. We are still investigating root cause for yesterday's and today's slow response times and will keep incident open until we have been able to better identity root cause. We are very sorry for the delays and we know this is hurting your productivity.

Next Steps: We will share further updates later today and latest tomorrow as we have been able to analyze options further.
Posted Mar 22, 2022 - 12:43 EDT
Update
We are continuing to investigate the issue.

The next update will be provided within the next 60 minutes (no later than 5:00 PM UTC)
Posted Mar 22, 2022 - 12:04 EDT
Investigating
Impact:
Citrix Content Collaboration - Podio is currently experiencing issues in all regions that would impact users. Users impacted are experiencing increased errors and delays in response times.

Current Status:
We are currently investigating the issue.

Next Steps:
Another update will be provided within the next 60 minutes (no later than 4:00 PM UTC).
Posted Mar 22, 2022 - 11:02 EDT
This incident affected: Web and API.