Citrix Podio Workflow Automation experiencing delays
Incident Report for Citrix Podio Status Page
Resolved
This incident has been resolved.
Posted Apr 22, 2022 - 15:52 EDT
Update
We are continuing to monitor for any further issues.
Posted Apr 22, 2022 - 13:30 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2022 - 13:24 EDT
Investigating
Citrix engineering team is aware and actively working on the issue
Posted Apr 22, 2022 - 12:10 EDT
This incident affected: Advanced Workflow Automation.