Citrix Podio facing intermittent delays
Incident Report for Citrix Podio Status Page
Resolved
This incident is now resolved and system is back to functioning as expected.
Posted Mar 08, 2022 - 05:18 EST
Update
The intermittent delays have reduced significantly. However we will monitor the system for some more time till the system normalises completely.
Posted Mar 08, 2022 - 04:31 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 08, 2022 - 04:27 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 08, 2022 - 04:19 EST
Update
We continue to investigate the issue and figuring out the cause for this slowness.
Posted Mar 08, 2022 - 04:00 EST
Investigating
We have noticed intermittent slowness and delays in Podio right now. Our team is investigating the issue and we will provide an update soon.
Posted Mar 08, 2022 - 03:35 EST
This incident affected: Web and API.