Podio is experiencing delay in Notifications delivery.

Incident Report for Podio Status Page

Resolved

This is incident ha been resolved . System is completely operational.
Posted 2 years ago. Sep 14, 2023 - 04:43 EDT

Monitoring

A fix is implemented and we are monitoring the status
Posted 2 years ago. Sep 14, 2023 - 04:30 EDT

Update

We are continuing to investigate this issue.
Posted 2 years ago. Sep 14, 2023 - 04:27 EDT

Investigating

We are investigating delay in the Podio notification. We will provide updates here as soon as possible.
Posted 2 years ago. Sep 14, 2023 - 04:19 EDT
This incident affected: Email.