Podio is temporarily unavailable

Incident Report for Podio Status Page

Resolved

This incident has been resolved. No further impact has been observed and we are considering this issue to be resolved based on feedback from customers and our system monitoring. If you are still experiencing any issues, please let us know via support at Help Center: https://support.sharefile.com/s/
We apologize for the impact of this issue for your business and are taking steps to reduce the likelihood of this occurring again in the future. We will share post-mortem details once we complete an internal review of events and analysis of the root cause.
Posted Jun 19, 2025 - 15:21 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 19, 2025 - 14:42 EDT

Investigating

We are investigating customer reports of Podio being unavailable. We will provide updates here as soon as possible.
Posted Jun 19, 2025 - 14:16 EDT
This incident affected: Web, API, and Email.