Workflow automation trigger delays
Incident Report for Citrix Podio Status Page
Resolved
This incident has been resolved.
Posted Mar 15, 2021 - 08:30 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 15, 2021 - 07:57 EDT
Investigating
We are currently investigating this issue.
Posted Mar 15, 2021 - 07:38 EDT
This incident affected: API and Advanced Workflow Automation.