Citrix Podio experiencing latency

Incident Report for Podio Status Page

Resolved

This incident has been resolved. If you are still facing issues, please contact Citrix Support Team.
Posted 3 years ago. Mar 21, 2022 - 14:45 EDT

Monitoring

The Citrix Engineering team scaled the resources and this should have resolved the issues faced by the customers.

The team will continue to monitor the issue. This will be the last communication until the resolution.
Posted 3 years ago. Mar 21, 2022 - 13:58 EDT

Update

Current Status:
We are currently investigating the issue looking into the logs and checking for any 3rd party issues that are causing this problem.

Next Steps:
Another update will be provided within the next 60 minutes (no later than 6:30 PM UTC).
Posted 3 years ago. Mar 21, 2022 - 13:42 EDT

Investigating

Citrix engineering team is currently investigating increased errors and delays in response times
Posted 3 years ago. Mar 21, 2022 - 12:15 EDT
This incident affected: Web and API.