Delays in background tasks and calculations
Incident Report for Citrix Podio Status Page
Resolved
This incident has been resolved.
Posted Jan 16, 2020 - 17:43 EST
Identified
The issue has been identified and the team is working on the fix.
Posted Jan 16, 2020 - 16:48 EST
Investigating
Podio is experiencing delays in background tasks and calculations. Updates will be posted here as we have them.
Posted Jan 16, 2020 - 16:28 EST