We have been monitoring the system for the past 2.5 hours and can confirm that all operations with Podio workflow automation are back to normal. Our team is relentlessly working to continue improving our infrastructure and avoid such issues in future. We apologize for the inconvenience caused by this issue and thank you for your patience and understanding.
Posted Jun 02, 2025 - 12:54 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 02, 2025 - 10:14 EDT
Identified
The issue has been identified and we are actively working on a resolution. We expect the experience to be back to normal shortly.
Posted Jun 02, 2025 - 08:49 EDT
Update
We are continuing to investigate this issue.
Posted Jun 02, 2025 - 08:09 EDT
Update
We are continuing to investigate this issue.
Posted Jun 02, 2025 - 08:02 EDT
Investigating
We are continuing to investigate this issue. The Engineering team is engaged and working on a fix. We regret the inconvenience caused and are trying our best to get Podio Workflow Automation up and running again
Posted Jun 02, 2025 - 08:01 EDT
This incident affected: Web, API, Email, Advanced Workflow Automation, and Advanced Workflow Automation Failover Queue.