Podio Workflow Automation experiencing delays
Incident Report for Citrix Podio Status Page
Resolved
This incident has been resolved.
Posted Mar 09, 2022 - 16:59 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 09, 2022 - 14:18 EST
Identified
Citrix engineering team is actively working on the issue
Posted Mar 09, 2022 - 14:03 EST
This incident affected: Advanced Workflow Automation Failover Queue.