Intermittent Issues on Podio
Incident Report for Podio Status Page
Resolved
The incident has been resolved.
Posted May 02, 2023 - 18:30 EDT
Monitoring
Podio performance is back to normal. But we will be monitoring the system for some more time to look out for any possible issues.
Posted May 02, 2023 - 17:29 EDT
Update
The errors and delays are reducing. We should be observing better performance now. But we continue to investigate and monitor the cause.
Posted May 02, 2023 - 17:21 EDT
Update
We are continuing to investigate this issue.
Posted May 02, 2023 - 17:03 EDT
Investigating
Podio seems to be down with intermittent access issues. We are currently investigating the issue.
Posted May 02, 2023 - 17:02 EDT
This incident affected: Web, API, Email, and Advanced Workflow Automation.