Workflow automation trigger delay
Incident Report for Citrix Podio Status Page
Resolved
This incident has been resolved.
Posted Mar 10, 2021 - 15:05 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 10, 2021 - 13:34 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 10, 2021 - 11:27 EST
This incident affected: Advanced Workflow Automation.